SweetFX Settings DB
Latest forum threads
54 minutes ago
57 minutes ago
1 hour, 32 minutes ago
1 hour, 40 minutes ago
V1.5 compatibility question
Posted 8 years, 7 months ago
Just discovered SweetFX. Is version 1.50/1.51 backward compatible with profiles created with versions 1.3 and 1.4? Thanks, raf
Posted 8 years, 7 months ago
Yes SweetFX is 100% backwards Compatible, You could even use older profiles with SweetFX 2.0.
New post

Please log in to post an answer